
Arduino & Friends
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Back in the day…

2
3
4
5
6
7
8
9

10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25

list p=16f84a
include
COUNT1 EQU 08h
COUNT2 EQU 09h

org 0x00
goto start

start bsf STATUS, RP0 ;bank 1
movlw 0xFE
movwf TRISB ;set all PORTB input except for RB0
bcf STATUS, RP0 ;bank 0

main bsf PORTB, 0 ;make RB0 high
call delay ;delay subroutine
bcf PORTB, 0 ;make RB0 low
goto main

delay
loop1 decfsz COUNT1,1 ;decrement COUNT1 variable until zero
goto loop1
decfsz COUNT2,1 ;decrement COUNT2, if not zero, go back to
loop1
goto loop1
return
end



Arduino Board

The name Arduino comes from a bar in Ivrea, Italy, where some of 

the founders of the project used to meet.

Created in 2005 by Massimo Banzi & David Cuartielles

Open Source Hardware

Processor

Coding is accessible & transferrable → (C++, Java etc)



Arduino…

is the go-to gear for hams, 
hobbyists, students, 
and anyone with a 
gadgetry dream.

rose out of 
another formidable 
challenge: how to teach 
students to create 
electronics, fast.



Getting Started

• SW Installation: Arduino (v.1.0+) 

Fritzing

Drivers (FTDI)



Analog 

INPUTS

Digital I\O
PWM(3, 5, 6, 9, 10, 11)

PWR IN USB 

(to Computer)

SCL\SDA
(I2C Bus)

POWER 
5V / 3.3V / GND

RESET



Arduino Shields

PCB Built Shield Inserted Shield



Arduino Shields

Micro SD MP3 Trigger LCD



Components

Push Button Digital Input Switch - Closes 
or opens circuit

Polarized, needs 
resistor

Trim 
potentiometer

Analog Input Variable resistor Also called a 
Trimpot.

Photoresistor Analog Input Light Dependent 
Resistor (LDR)

Resistance varies 
with light.

Relay Digital Output Switch driven by 
a small signal

Used to control 
larger voltages

Temp Sensor Analog Input Temp Dependent 
Resistor

Flex Sensor Analog Input Variable resistor

Soft Trimpot Analog Input Variable resistor Careful of shorts

RGB LED Dig & Analog 
Output

16,777,216 
different colors

Ooh... So pretty.

Name Image Type Function Notes



Components



Components





Super cheap shield £4.50



Prototyping Circuits 

Solderless Breadboard

One of the most useful tools in an engineer or 

Maker’s toolkit. The three most important 

things:
• A breadboard is easier than soldering

• A lot of those little holes are connected, which ones?

• Sometimes breadboards break



What’s a Breadboard?



Solderless Breadboard

Each row (horiz.) of 5 

holes are connected.

Vertical columns –

called power bus are 

connected vertically



Using the Breadboard to built a simple 

circuit

Use the breadboard to 

wire up a single LED 

with a 330 Ohm 

Resistor (Orange-

Orange-Brown).

Note: the longer leg on the 

LED is the positive leg and 

the shorter leg is the 

negative



Fritzing View of Breadboard Circuit

What happens 

when you break 

the circuit?

What if you 

wanted to add 

more than one 

LED?



Adding control – let’s use the Arduino

and start programming!!!



Concepts: INPUT vs. OUTPUT

Referenced from the perspective of the microcontroller (electrical board).

Inputs is a signal / information 

going into the board.

Output is any signal exiting the 

board.

Almost all systems that use physical computing will have 

some form of output

What are some examples of Outputs?



Concepts: INPUT vs. OUTPUT

Referenced from the perspective of the microcontroller (electrical board).

Inputs is a signal / information 

going into the board.

Output is any signal exiting the 

board.

Examples: Buttons Switches, 

Light Sensors, Flex Sensors, 

Humidity Sensors, Temperature 

Sensors…

Examples: LEDs, DC motor, 

servo motor, a piezo buzzer, 

relay, an RGB LED



Concepts: Analog vs. Digital

Microcontrollers are digital devices – ON or OFF.  

Also called – discrete.

analog signals are anything that can be a full 

range of values.  What are some examples? More 

on this later…

5 V

0 V

5 V

0 V



Arduino
Integrated Development Environment (IDE)

Two required functions / 
methods / routines:

void setup()

{

// runs once

}

void loop()

{

// repeats

}error & status messages



Settings:  Tools → Serial Port

Your computer 

communicates to the Arduino

microcontroller via a serial 

port → through a USB-Serial 

adapter.

Check to make sure that the 

drivers are properly installed.



Settings:  Tools → Board

Next, double-check that the proper board is selected under the 

Tools→Board menu.



Arduino & Arduino Compatible Boards



digitalWrite()

analogWrite()

digitalRead()

if() statements / Boolean

analogRead()

Serial communication
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Let’s get to coding…

Project #1 – Blink

“Hello World” of Physical Computing

Psuedo-code – how should this work?

Turn 
LED ON

Wait
Turn 
LED 
OFF

Wait
Rinse & 
Repeat



Comments, Comments, Comments

Comments are for you – the programmer and your 

friends…or anyone else human that might read your 

code.

// this is for single line comments

// it’s good to put a description at the 

top and before anything ‘tricky’

/* this is for multi-line comments

Like this…  

And this….

*/



comments



Three commands to know…

pinMode(pin, INPUT/OUTPUT);

ex: pinMode(13, OUTPUT);

digitalWrite(pin, HIGH/LOW);

ex: digitalWrite(13, HIGH);

delay(time_ms);

ex: delay(2500); // delay of 2.5 sec.

// NOTE: -> commands are CASE-sensitive



Project #1: Wiring Diagram

Move the green 

wire from the 

power bus to pin 

13 (or any other 

Digital I/O pin on 

the Arduino board.

Image created in Fritzing



A few simple challenges

Let’s make LED#13 blink!

Challenge 1a – blink with a 200 ms second 

interval.

Challenge 1b – blink to mimic a heartbeat

Challenge 1c – find the fastest blink that the 

human eye can still detect…

1 ms delay?  2 ms delay?  3 ms delay???



Try adding other LEDs



Programming Concepts:  Variables

Variable Scope

Global 

---

Function-level



Programming Concepts:  Variable Types

Variable Types:

8 bits 16 bits 32 bits

byte 

char

int

unsigned int

long

unsigned long

float



Fading in and Fading Out 

(Analog or Digital?)

A few pins on the Arduino allow for us to 

modify the output to mimic an analog 

signal.

This is done by a technique called:

Pulse Width Modulation (PWM)



Concepts: Analog vs. Digital

To create an analog signal, the microcontroller 

uses a technique called PWM. By varying the duty 

cycle, we can mimic an “average” analog voltage.

Pulse Width Modulation (PWM)



analogWrite(pin, val);

pin – refers to the OUTPUT pin 

(limited to pins 3, 5, 6, 9, 10, 11.) 

– denoted by a ~ symbol

val – 8 bit value (0 – 255).  

0 => 0V    |    255 => 5V  

Project #2 – Fading

Introducing a new command…



Move one of your LED pins over to Pin 9

In Arduino, open up:

File → Examples → 01.Basics → Fade



Fade - Code Review



Fade - Code Review



Color Mixing

Tri-color LED

This a standard – Common 

Cathode LED

This means the negative side of 

the LEDs are all tied to Ground.

R G B



Project 3 – RGB LED

Note: The longest 

leg of the RGB 

LED is the 

Common 

Cathode. This 

goes to GND.

Use pins 5, 6, & 9



How many unique colors can you create?

Use Colorpicker.com or 

experiment on your 

own.

Pick out a few colors that 

you want to try re-

creating for a lamp or 

lighting display...

Play around with this with 
the analogWrite()

command.



RGB LED Color Mixing

int redPin = 5;

int greenPin = 6;

int bluePin = 9;

void setup()

{

pinMode(redPin, OUTPUT);

pinMode(greenPin, OUTPUT);

pinMode(bluePin, OUTPUT);

}



RGB LED Color Mixing

void loop()

{

analogWrite(redPin, 255);

analogWrite (greenPin, 255);

analogWrite (bluePin, 255);

}



Project: Mood Lamp / Light Sculpture



Driving Motors or other High Current 

Loads

NPN Transistor (Common Emitter “Amplifier” Circuit)

to Digital

Pin 9



Input

Input is any signal entering an electrical system.

• Both digital and analog sensors are forms of input

• Input can also take many other forms: Keyboards, a 

mouse, infrared sensors, biometric sensors, or just 

plain voltage from a circuit



Project #4 – Digital Input

In Arduino, open up:

File → Examples → 02.Digital → Button



Digital Sensors (a.k.a. Switches)

Pull-up Resistor (circuit)

to Digital Pin 2

http://falstad.com/circuit/#%24+4+5.0E-6+10.20027730826997+50+5.0+43%0Ar+240+224+240+320+0+10000.0%0Ag+240+320+240+368+0%0As+240+224+240+128+0+1+true%0AR+240+128+240+80+0+0+40.0+5.0+0.0+0.0+0.5%0Aw+240+224+304+224+0%0AM+304+224+352+224+0+2.5%0Ax+301+257+412+261+0+16+to+Digital+Input+3%0A
http://falstad.com/circuit/#%24+4+5.0E-6+10.20027730826997+50+5.0+43%0Ar+288+160+288+256+0+10000.0%0AR+288+160+288+128+0+0+40.0+5.0+0.0+0.0+0.5%0Aw+288+256+336+256+0%0As+288+256+288+336+0+1+true%0Ag+288+336+288+368+0%0AM+336+256+384+256+0+2.5%0A
http://falstad.com/circuit/#%24+4+5.0E-6+10.20027730826997+50+5.0+43%0Ar+240+224+240+320+0+10000.0%0Ag+240+320+240+368+0%0As+240+224+240+128+0+1+true%0AR+240+128+240+80+0+0+40.0+5.0+0.0+0.0+0.5%0Aw+240+224+304+224+0%0AM+304+224+352+224+0+2.5%0Ax+301+257+412+261+0+16+to+Digital+Input+3%0A


Digital Sensors (a.k.a. Switches)

Add an indicator LED to Pin 13

This is just like our 

1st circuit!



Digital Input

• Connect digital input to your Arduino using Pins # 0 – 13  

(Although pins # 0 & 1 are also used for programming)

• Digital Input needs a pinMode command:

pinMode (pinNumber, INPUT); 

Make sure to use ALL CAPS for INPUT

• To get a digital reading: 

int buttonState = digitalRead (pinNumber);

• Digital Input values are only HIGH (On) or LOW (Off)



Digital Sensors

• Digital sensors are more straight forward than Analog

• No matter what the sensor there are only two 

settings: On and Off

• Signal is always either HIGH (On) or LOW (Off)

• Voltage signal for HIGH will be a little less than 5V on 

your Uno

• Voltage signal for LOW will be 0V on most systems





Programming:  Conditional Statements
if()



void loop()

{

int buttonState = digitalRead(5);

if(buttonState == LOW)

{ // do something

}

else

{  // do something else

}

}

Programming:  Conditional Statements
if()

DIG 

INPUT



Boolean Operators

<Boolean> Description

( ) == ( ) is equal?

( ) != ( ) is not equal?

( ) > ( ) greater than

( ) >= ( ) greater than or equal

( ) < ( ) less than

( ) <= ( ) less than or equal



Trimpot (Potentiometer)

Variable Resistor

wiper

fixed

end

fixed

end



Analog Sensors
3 Pin Potentiometer = var. resistor (circuit)

a.k.a. Voltage Divider Circuit

1.0 V 1.0 V

wiper

fixed

ends

http://falstad.com/circuit/#%24+4+5.0E-6+10.20027730826997+50+5.0+43%0Ar+400+224+400+320+0+2000.0%0Ag+400+320+400+368+0%0AR+400+128+400+80+0+0+40.0+5.0+0.0+0.0+0.5%0Aw+400+224+464+224+0%0Ar+400+128+400+224+0+8000.0%0A174+160+176+160+272+0+10000.0+0.797+Resistance%0Aw+176+224+224+224+0%0AO+464+224+528+224+1%0AR+160+176+160+80+0+0+40.0+5.0+0.0+0.0+0.5%0Ag+160+272+160+368+0%0AO+224+224+288+224+1%0A


analogRead()

Arduino uses a 10-bit A/D Converter:

• this means that you get input values from 

0 to 1023

• 0 V → 0

• 5 V → 1023

Ex:

int sensorValue = analogRead(A0);



Using Serial Communication

Method used to transfer data between two devices.

Arduino dedicates Digital I/O pin # 0 to 

receiving and Digital I/O pin #1 to transmit.

Data passes between the computer and Arduino 

through the USB cable. Data is transmitted as zeros 

(‘0’) and ones (‘1’) sequentially.



Serial Monitor & analogRead()

Initializes the Serial 

Communication

9600 baud data rate

prints data to serial bus



Serial Monitor & analogRead()

Opens up a 

Serial Terminal 

Window



Analog Sensors

Examples:

Sensors Variables

Mic soundVolume

Photoresistor lightLevel

Potentiometer dialPosition

Temp Sensor temperature

Flex Sensor bend

Accelerometer tilt/acceleration



Additional Serial Communication

Sending a Message

void loop ( ) 

{

Serial.print(“Hands on “) ;

Serial.print(“Learning ”) ;

Serial.println(“is Fun!!!”) ;

}





Serial Communication:

Serial Debugging 

void loop() 

{

int xVar = 10;

Serial.print ( “Variable xVar is “ ) ;

Serial.println ( xVar ) ;

}



Serial Communication:

Serial Troubleshooting

void loop ( ) 

{

Serial.print (“Digital pin 9: “);

Serial.println (digitalRead(9));

}



Virtual Electrical Prototyping Project 

started in 2007 by the Interaction Design Lab 

at the University of Applied Science Potsdam, Germany

Open Source

Prototypes: Document, Share, Teach, Manufacture



Other Boards

Each has their own advantages and 

costs.

Netduino

GHI Fez

ESP8266

ESP32

Teensy

Picaxe



QUESTIONS?


